Back to overview
Degraded

Report Generation Issues

Aug 05 at 08:16am EDT
Affected services
Dashboard

Resolved
Aug 05 at 02:20pm EDT

The issue affecting report generation has been fully resolved. All report types should now be functioning as expected.

We’ve confirmed successful processing across the platform and will continue to monitor closely to ensure stability.

Thank you for your patience, and please reach out to support if you encounter any further issues.

Updated
Aug 05 at 12:25pm EDT

Most report generation requests are now processing successfully. However, some users may still encounter intermittent errors on specific report types.

If you continue to experience issues, please reach out to our support team — we’re happy to assist by generating and delivering reports manually.

We’re continuing to monitor the system closely and will share another update once full functionality is confirmed.

Created
Aug 05 at 08:16am EDT

We are currently investigating an issue where some users are experiencing delays or errors when generating reports. The issue appears to be intermittent and may not affect all users.

Our engineering team is actively working to identify the root cause.

In the meantime, if you need assistance with urgent reports, please reach out to our support team — they can help generate and deliver reports manually as needed.

We’ll share an update as soon as we have more information.